Source of Adobe zero-day bug patched

By on

One of the flaws at the heart of Adobe's ColdFusion 8.0.1 zero-day vulnerability has been patched.

Recent attacks were due, in part, to a vulnerable text-editor bundled with web design and development platform ColdFusion, according to Adobe. It had been shipped with an open source text editor called FCKeditor, versions of which contained a security hole.

“Adobe is aware of reports of ColdFusion websites being compromised through a vulnerability in the FCKeditor rich text editor,” David Lenoe, Adobe product security program manager, wrote in a post on the company's Product Security Incident Response Team (PSIRT) blog.

He said Adobe is working on a fix, which is expected to be made available this week. He also outlined a workaround in the post.

In the meantime, a new version of FCKeditor has been released to address the vulnerability. In an advisory, US-CERT said that it “encourages users and administrators to upgrade to FCKeditor version to help mitigate the risks.”

The FCKeditor vulnerability was “due to improper verification of input passed to the ‘CurrentFolder' parameter," US-CERT said in its advisory. "Exploitation of this vulnerability may allow an attacker to execute arbitrary code.”

ColdFusion also suffered from a second attack vector through vulnerable FCKeditor installations.

“One of the common applications that has been seen in attacks is CFWebstore, a popular e-commerce application for ColdFusion,” wrote Bojan Zdrnja, senior information security consultant at Infigo IS, in an updated post on the SANS Internet Storm Center. "Older versions of CFWebstore used a vulnerable FCKeditor installation. If you are using CFWebstore, make sure that you are running the latest version and that any leftovers have been removed.”

See original article on

Copyright © SC Magazine, US edition

Most Read Articles

Log In

|  Forgot your password?